Derniers sujets
» Alimentation/Chargeur 60V/400W CC/CV tout prêt
Mar 20 Juin 2017 - 22:09 par Silicium81

» Regulateur MPP universel
Ven 16 Juin 2017 - 13:10 par Silicium81

» Remorque monoroue et charge changeante
Mer 7 Juin 2017 - 14:15 par filomat

» caddie solaire
Jeu 1 Juin 2017 - 11:19 par filomat

» VTT AE sur base RR9.2
Jeu 1 Juin 2017 - 8:49 par Silicium81

» Vous avez dit "Chromebook" ?
Dim 21 Mai 2017 - 21:11 par filomat

» controleur sinus miniature ...
Mar 9 Mai 2017 - 18:23 par gui13

» Chargeur 1800W / 40..60V et 1,5 kg (origine serveur)
Sam 22 Avr 2017 - 9:55 par Snickers

» Moteur roue sur ligne de chaine
Mar 18 Avr 2017 - 0:15 par zenedavtri


SmartBMS OZ890

Page 3 sur 4 Précédent  1, 2, 3, 4  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Ven 19 Déc 2014 - 16:03

de rien Patrick
Chaipaki a écrit:
Ouais tu as raison je vais tester de changer le fet de charge. (Pas besoin de tous les changer pour l’instant ?)
si ca change rien je testerais de faire la modif Shunt de JC.
et si ca change encore rien ...   affraid   on verra  bien.
Merci encore de votre aide.
++
attention, ce sont les 2 ou 3 mosfet de décharge qu'il faut changer, ce sont eux qui sont utilisé comme shunt
le mosfet de charge n'est pas critique

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Chaipaki le Mar 23 Déc 2014 - 1:47

Merci J.Christophe heureusement que tu as vu !

Sinon juste pour voir jai testé les resistances CF0 > CF13
la cf0 a l’air grillée la resistance au ohmetre est tres faible par rapport aux autre 0,022 (sur2k)
les autres cfx... ocillent autour de 10,8. (Sur 20k) (sans la batterie conectée)
Aussi il n’y a pas de voltage lorsque je prend la tension derriere (cf0>cf1) toutes les autres tensions derrieres les cfx ont l’air ok. Environ 3,7v.(batterie branchée)

Ça peut avoir une incidence non?! Je connait pas les valeurs des autres resistances de la carte pour les tester correctement comme les c1... c6c7 etc.
Certaine c1 c5 = 0,07 (sur200) sont tres faible mais je nai pas de reference...

Chaipaki

Messages : 10
Date d'inscription : 21/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Silicium81 le Mar 23 Déc 2014 - 10:23

Il est plus probable qu'il y ai un élément en dérivation avec CF0 qui trompe l'ohmètre... Il est quasi impossible qu'une résistance voit sa valeur devenir nulle (en cas de problème elle se coupe plutôt et sa résistance augmente).
avatar
Silicium81
Admin

Messages : 356
Date d'inscription : 10/04/2014
Localisation : Tarn

http://vae-tech.forumactif.org

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Mar 23 Déc 2014 - 21:07

oui, et en plus:
CFx,ce sont des capacités, les résistances ca commence par R.
CF0, c'est la capacité entre le - des fils d’équilibrage et la masse de puissance.
a premiere vue, ca me parait donc normal qu'il n'y ai pas de tension.
voir le schéma dans sur première page.

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Chaipaki le Mar 23 Déc 2014 - 22:47

Arf... et moi qui pensé avoir trouvé la panne. Smile
Si ce sont des condensateurs Je comprends mieux pourquoi la valeur mesurée a leur bornes évoluait apres avoir debranché la batterie...
Je pensé pas que des condensateurs pouvait etre si petit.

Chaipaki

Messages : 10
Date d'inscription : 21/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Chaipaki le Sam 27 Déc 2014 - 3:29

Finalement je vais laisser tomber le changement des mosfets et plutot repartir sur du neuf en rachetant un bms.
Si je commande le même pour une batterie lipo 13s lithium polymer 48v 15A, quels sont les parametres les plus adapté, pour le overcurent et le low voltage?
Javais demandé 4,20 et 3,00v pour celui qui ne fonctione plus.

Y a t il un avantage a avoir l’equilibrage permanent ?

Chaipaki

Messages : 10
Date d'inscription : 21/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Gnongris le Dim 28 Déc 2014 - 21:04

3.00v en niveau bas c'est trop bas pour du lipo si tu es en lipo. dans ce cas la 3.3 3.5v c'est le minimum.
avatar
Gnongris

Messages : 22
Date d'inscription : 15/06/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Chaipaki le Dim 28 Déc 2014 - 22:48

Ok ok,
Et pour la coupure en fin de charge 4,20 ou 4,25.
Car actuellement la coupure a lieu a 4,16 alors qu'il est censé couper a 4,20.
Du coup le pac termine sa charge vers 54,2 au lieu de 54,6...

Chaipaki

Messages : 10
Date d'inscription : 21/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Gnongris le Lun 29 Déc 2014 - 9:46

4.20 est le maximum admissible pour un lipo au dessus de 4.25 ton lipo est mort. A 4.16 tu as plus de 95% de charge et dés que tu consommes un peu la tension vas chuter au cause de la résistance interne de l'accus. Ne pas dépasser 4.15 en tension maxi de charge et 3.7 en décharge permet d'augmenter la durée de vie d'un pack mais en réduit la capacité utilisable.

Ne pas oublier non plus que la tension du pack vas aussi chuter avec la diminution de la capacité du pack.
avatar
Gnongris

Messages : 22
Date d'inscription : 15/06/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Lun 29 Déc 2014 - 10:44

par expérience sur 3 achat d'environ 10 smartbms, bmsbattery ne fait aucune adaptation sur la programmation (tension, mode d’équilibrage).
ils adaptent seulement le nombre de cellules et gardent l’équilibrage en fin de charge qui ne marche pratiquement pas.
ils ont peut être 3 config (lipo linm et lifepo)
les seuils sont de mémoire 2.7v et 4.2v pour du limn.(pour le seuil bas, il faut tenir compte de la chute de tension de la resistance interne du pack. sur les petits pack, il faut donc eventuelement abaisser la tension minimum.)

de plus sans la modif shunt externe, ce bms me semble inutilisable.

je ne crois pas que ce soit une bonne idée d'en racheter si tu ne comptes pas faire la mofif shunt et que tu n'as pas d'outils de programmation.


Dernière édition par jean-christophe le Lun 29 Déc 2014 - 23:57, édité 1 fois

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Gnongris le Lun 29 Déc 2014 - 21:19

Voila le fichier d'origine que programme BMS Battery. ils ne sont pas toujours identiques. Celui la est de décembre 2014.





Comme tu le vois si tu fais la modif du shunt il te faut en trouver un de 2mohms si tu n'as pas la possibilité de reprogrammer le bms. Par contre les seuil de coupure bas sont mauvais et  si il y a un pb tu ne pourras pas comprendre d'ou cela vient ni recalibrer le bms en courant et en tension ... A toi de voir.
avatar
Gnongris

Messages : 22
Date d'inscription : 15/06/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Gnongris le Lun 29 Déc 2014 - 21:53

Voila a peut près ce que je programme et qui marche bien avec des pack petits (5.8Ah 13s lipo) sur lesquels je tire jusqu'à 33 A (ou 1500W maxi en comptant la chute de tension par résistance interne). Je préfère utiliser deux petites batteries que je change pendant ma sortie pour garder un vélo lègé.



avatar
Gnongris

Messages : 22
Date d'inscription : 15/06/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Chaipaki le Mar 30 Déc 2014 - 0:27

Aïe, merci pour ces précieux commentaires.
bmsbattery demandent de préciser les seuils de tension à la commande...
C est donc juste pour faire jolie...
Est ce que le shunt est utile sachant que je compte mettre un relais 48v en sortie du bms pour deconnecter la batterie du controlleur?

Chaipaki

Messages : 10
Date d'inscription : 21/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Mer 7 Jan 2015 - 12:59

heu ?
comment va tu commander le relais ?
j'ai l'impression que le relais va ajouter des problemes à la place de les resoudre.

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Gnongris le Mer 7 Jan 2015 - 18:32

Ton relais si c'est pour démarrer et arrêter l'alimentation fait plutôt ce montage là. Il marche très bien Interrupteur mosfet édit : dont le lien sur ce forum est dans le message ci dessous, mais je ne m'en souvenais plus.




Ou bien il y a cela  dont on parle ici si tu ne veux rien bricoler mais c'est gros et moche.

Un relais c'est une mauvaise idée : consommation du relais pendant utilisation, étincelle sur les contact et courant fort = durée de vie du relais faible et échauffement au niveau des contact (la résistance va augmenter avec l'usure et le temps sans compter la chute de tension)


Dernière édition par Gnongris le Mer 7 Jan 2015 - 21:00, édité 3 fois
avatar
Gnongris

Messages : 22
Date d'inscription : 15/06/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Silicium81 le Mer 7 Jan 2015 - 19:04

avatar
Silicium81
Admin

Messages : 356
Date d'inscription : 10/04/2014
Localisation : Tarn

http://vae-tech.forumactif.org

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par dirk pitt le Dim 11 Jan 2015 - 11:39

merci (a retardement) jean christophe pour ta reponse tres claire. ce pendant, je ne vois pas vraiment l'interet de la modif permettant de laisser le controleur branché mais hors tension. enfin, ça depend peut-etre des controleurs mais certains ont leur propre mise hors tension.

dirk pitt

Messages : 12
Date d'inscription : 16/12/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Mer 2 Mar 2016 - 13:35

j'ai retrouvé ma batterie a 4.4v par cellule hier
il y a apparemment 2 pannes:

- le chargeur (de bmsbattery) que j'avais réglé a (52v) 4.0v*13 était a 58v.
- le mosfet de charge du smart bms a l'air d'être claqué car la charge ne s’arrête pas.
le smart bms dialogue toujours avec le pc et les réglages sont toujours bien la (4.1v/cell)

les 2 pannes ne se sont probablement pas produite en même temps car si 1 des 2 protections fonctionne, le système marche correctement.

j'ai vérifier le chargeur et j'ai tourné le pot de tension d'un tour a gauche, la tension s'est effondrée puis j'ai du revenir grosso modo a la position initiale pour le bon réglage de tension de 52v.
pas très rassurant...

je vais devoir ajouter une protection supplémentaire ou faire des vérifications systématiques


Dernière édition par jean-christophe le Mer 2 Mar 2016 - 20:44, édité 2 fois

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Silicium81 le Mer 2 Mar 2016 - 17:26

4,4V affraid

De l'importance de bien régler la tension maxi du chargeur ! (et de la vérifier de temps en temps...
avatar
Silicium81
Admin

Messages : 356
Date d'inscription : 10/04/2014
Localisation : Tarn

http://vae-tech.forumactif.org

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Jeu 3 Mar 2016 - 9:41

bon
j'ai vérifié le smart bms,
je n'ai pas du faire de reset,
le mosfet de charge n'est pas claqué
j'ai essayé différente tension de charge, différent courant, une charge et une décharge simultanée
pas moyen de le mettre en défaut, tout fonctionne correctement
le mystère reste entier, ce n'est pas très rassurant.
ce qui est sur c'est que c'est la première fois que cela arrive car je contrôle toujours la tension sur le Cycle analyste quand je démarre)

je pense faire un module supplémentaire (a intercaler entre la batterie et le chargeur)

fonction:

minuterie (démarrage a une certaine heure pour un temps max)
tension de charge (comme le smartbms fait l'équilibrage en permanence, on peut faire varie la tension sans problème)
coupure avec un relais (pour changer des mosfet, je deviens superstitieux!)

le satiator fait ca d'origine je crois mais pour 300$+taxe

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Silicium81 le Jeu 3 Mar 2016 - 10:15

Sur mon BMS, j'ai mis une surveillance de la tension maxi. Si elle dépasse un seuil fixé, la charge est interrompue. (je l'ai réglée à 0,5V au dessus de la tension finale normale du pack qui est pour moi de 3,6 x 12 = 43,2 soit 43,7V cela donne 0,5 / 12 = 41 mV par élément )
avatar
Silicium81
Admin

Messages : 356
Date d'inscription : 10/04/2014
Localisation : Tarn

http://vae-tech.forumactif.org

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Jeu 3 Mar 2016 - 10:33

oui ca aurait été suffisant dans mon cas

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par hube68 le Ven 4 Mar 2016 - 8:53

Le OZ 890 est un IC génial... Quand il fonctionne comme dans sa datasheet, c'est à dire assez souvent.

Il a parfois des comportements bizarres, surtout, après toute "intervention" sur la programmation du OZ ou sur les connexions de cellules autour, toujours bien le ressetter.

Par ailleurs, la fonction (hyperimportante) de mesure de tension (les 10 ou 13 valeurs individuelles) au millivolt près n'est pas toujours si précise que ça. Il est nécessaire de faire (et/ou vérifier) la calibration du circuit (une des fonctions de cowboy) avec l'aide d'un bon voltmètre numérique. Comme cette cal se fait juste sur un seul point de fonctionnement et qu'on ne sait pas l'impact que cela a ailleurs (fonction proportionnelle, affine?), il faut faire la cal à proximité du point critique, donc en gros entre 4,0 et 4,2V par cellule.
avatar
hube68

Messages : 108
Date d'inscription : 16/02/2015
Localisation : FR-68-Colmar

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par jean-christophe le Ven 4 Mar 2016 - 10:27

bonjour hube68, merci pour ton retour

en ce qui me concerne c'est la première fois que je constate un dysfonctionnement du chip et encore je ne suis pas sur que ça vienne du chip. en général ça marche ou le chip est claqué.

par contre pour l'erreur de mesure, j'ai constaté un problème sur une carte smartbms.

symptôme: la batterie ne gardait pas sa tension après la charge a 4.1v
toute les tensions rapportées par le soft étaient bien équilibrée après la charge et a la bonne valeur.

après analyse, plusieurs cellule étaient bien trop hautes (et donc elles redescendaient rapidement) et d'autre trop basse, l'erreur de mesure via l'interface était énorme: 0.2-0.3v.
j'ai d'abord essayer une calibration mais il y a avait toujours un problème.

il y a avait plusieurs condensateurs défectueux CFx (1uf) sur la carte qui consommaient du courant et faisait donc chuter la tension via la résistance série avant la mesure du chip.

le problème est survenu après un certain temps car pendant le test initial, tout était correct.

donc pour bien faire il faut quand même, de temps en temps, contrôler manuellement les tensions avec un multimètre. pas cool les composants chinois.


Dernière édition par jean-christophe le Ven 4 Mar 2016 - 13:42, édité 2 fois

jean-christophe

Messages : 82
Date d'inscription : 10/05/2014

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par hube68 le Ven 4 Mar 2016 - 11:07

non pas cool.

Dans le même genre j'ai déjà vu aussi des BMS avec des petits transistors (pour commuter des résistances d'équilibrage extérieures) fuiteux et/ou mal soudés. Conséquence, décharge progressive d'une cellule (ou plusieurs) impossible à rééquilibrer tout seul et qui conduit d'abord à une baisse notable de la capacité utilisable du pack puis finalement à la mort de la cellule. Le BMS tueur!

Lorsqu'il y a des résistances d'équilibrage extérieures, il faut absolument vérifier, au moins au début, que "au repos" la tension aux bornes de chacune de ces résistances soit bien à 0,0mV.
avatar
hube68

Messages : 108
Date d'inscription : 16/02/2015
Localisation : FR-68-Colmar

Revenir en haut Aller en bas

Re: SmartBMS OZ890

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 3 sur 4 Précédent  1, 2, 3, 4  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum